Search references for GUERNSEY RFC. Phrases containing GUERNSEY RFC
See searches and references containing GUERNSEY RFC!GUERNSEY RFC
Rugby union club in the Channel Islands
2019–20 season. The Guernsey Raiders Ladies team plays in level 4, Women's National Challenge 1 South East (South). Guernsey RFC were founded in 1928
Guernsey_RFC
English Channel island near Normandy
sport in Guernsey, the main club is accredited and governed by the Rugby Football Union (RFU). Guernsey RFC has 2 senior men’s teams (Guernsey Raiders
Guernsey
Elizabeth College. Guernsey RFC was founded in 1928 and competes in the English leagues. There is only one other club in Guernsey, St Jacques Vikings
Rugby union in the Bailiwick of Guernsey
Rugby_union_in_the_Bailiwick_of_Guernsey
Overview of and topical guide to the Bailiwick of Guernsey
Climb Rugby in Guernsey Guernsey RFC Siam Cup Sport Facilities in Guernsey Footes Lane The Track The Corbet Field Economy of Guernsey Economic rank, by
Outline of the Bailiwick of Guernsey
Outline_of_the_Bailiwick_of_Guernsey
Topics referred to by the same term
of the Bangladesh Navy Guernsey Cricket Board Guernsey FA Cup Guernsey F.C., association football Guernsey RFC, rugby Guernsey's, an auction house in New
Guernsey_(disambiguation)
Sports stadium in Guernsey
stadium of the Bailiwick of Guernsey. The stadium is used for a number of sports and by the rugby union team, Guernsey RFC who play in National League
Footes_Lane
The culture of Guernsey in the Bailiwick of Guernsey is a culture which has been shaped by its indigenous Norman language and traditions as well as French
Culture_of_Guernsey
Jerseyman rugby player (born 1981)
season. In 2015, he returned to play his final first-team match against Guernsey RFC in the Siam Cup, which Jersey won for the seventh consecutive year. "Jersey
Jon_Brennan
Level five league in the English rugby union system
2 South as champions along with Guernsey Raiders who won the virtual promotion play-off against Weston-super-Mare RFC, while teams relegated from the
Regional_1_South_East
Cup is an annual Rugby Union competition held between Jersey Reds and Guernsey RFC. It was first contested in 1920. The trophy awarded its winner is the
Rugby_union_in_Jersey
This page list topics related to the Bailiwick of Guernsey, including Guernsey, Alderney, Sark and smaller islands. Contents: Top 0–9 A B C D E F G H
Index of Guernsey-related articles
Index_of_Guernsey-related_articles
List of rugby union awards
pentru prima oara Cupa Pershing". 8 November 2014. "History — Siam Cup". Guernsey RFC. Archived from the original on 20 October 2012. Retrieved 5 May 2011
Rugby union trophies and awards
Rugby_union_trophies_and_awards
Guernsey participates in its own right in the Commonwealth Games. Guernsey participates in the bi-annual Island Games, which it hosted in 1987, 2003 and
Sport_in_Guernsey
Annual rugby competition
competition, Jersey had won 64 times, with Guernsey winning 19. There has only ever been one draw. "Siam cup". Jersey RFC. Retrieved 5 May 2011. "Siam Cup Preview"
Siam_Cup
English Rugby Union Regional League
try-filled afternoon". Guernsey Press. 8 April 2024. "PROMOTED AS CHAMPIONS – SANDOWN & SHANKLIN RFC EARN HISTORIC WIN AWAY AT WINCHESTER RFC". Island Echo. 9
Counties_1_Hampshire
Jersey rugby union player
made his debut for Jersey in 2010 in their annual Siam Cup game against Guernsey RFC. He later played in Jersey's National League 3 London & SE play-off Final
Myles_Landick
Jersey rugby union club, based in St Peter, Jersey
Athletic but separated in 2022 and are now known by the original name, Jersey RFC. The 1st XV play in National League 2 East – a league at level 5 of the English
Jersey_RFC
English rugby union club, based in London
Elms location in 1987 when the grounds were sold to form a school. Barnes RFC first XV has been promoted eight times since being positioned in Surrey Division
Barnes_RFC
Rugby player
Morriston RFC and made his debut for the Ospreys regional team in 2015 having previously played for the Ospreys academy, Aberavon RFC and Swansea RFC, while
Joe_Thomas_(rugby_union)
English rugby union club, based in Northamptonshire
Oundle RFC. 22 August 2025. "2015-2016 Midlands Division". England Rugby. RFU. Retrieved 2 May 2016. "Oundle Make It To Midlands 1!". Oundle RFC (Pitchero)
Oundle_RFC
England international rugby union player
raised in Guernsey, Carey was the son of barrister Sir Thomas Godfrey Carey, who served as both the attorney-general and bailiff of Guernsey. He attended
Godfrey_Carey
to find us". Jersey RFC. 1 November 2010. Retrieved 21 August 2011. Batiste, Rob (17 May 2011). "Saving Siam plan". This Is Guernsey. Retrieved 22 August
St._Peter_(rugby_ground)
Rugby union competition in England
to high winds our opponents Guernsey could not come across the channel today and our clash postponed". Facebook. Dorking RFC. 23 November 2024. "Results"
2024–25 National League 2 East
2024–25_National_League_2_East
English rugby union club, based in Hertfordshire
Rugby Football Club. The women's section were originally part of St Albans RFC, based in Smallford, which formed in 1989 from only four female players and
Old_Albanian_RFC
English rugby union club, based in Oxfordshire
Harlequins RFC was formed in 1996 following the merger of Oxford Marathons RFC and Oxford Old Boys RFC. In 2015 a possible merger between Oxford RFC and Oxford
Oxford_Harlequins_RFC
English rugby union club, based in Kent
Canterbury RFC is an English rugby union football club based in Canterbury, Kent. The club currently play in the fourth tier of English club rugby, participating
Canterbury_RFC
English rugby union club, based in Havant, Hampshire
Havant RFC is an English rugby union club and is a member of the Hampshire RFU. The men's 1st XV currently play in the RFU's National League 2 East, a
Havant_RFC
English rugby union team, based in London
respectively for England. In 1874 the club changed its name to Wimbledon RFC. It has been suggested that the change in name was due to the club's L J
Wimbledon_RFC
oldest known rugby union competitions. "United Hospitals RFC Club History". United Hospitals RFC. Archived from the original on 1 March 2010. Retrieved
List of oldest rugby union competitions
List_of_oldest_rugby_union_competitions
English rugby union club, based in Sevenoaks, London
All Guns Blazing!". London Cornish RFC (Pitchero). 30 April 2016. "KENT FINALS DAY - RESULTS". Old Dunstonian RFC (Pitchero). 21 June 2013. "2018-2019
Sevenoaks_RFC
Internet top-level domain generally used by or reserved for a country
end-user application. Creation and delegation of ccTLDs is described in RFC 1591, corresponding to ISO 3166-1 alpha-2 country codes. While gTLDs have
Country_code_top-level_domain
Les Quennevais R.F.C. was a rugby union club based in Jersey in the Channel Islands. LQRFC were formed in 1980 from a highly successful team from Les
Les_Quennevais_Rugby_Club
Rugby union competition in England
on 30 March 2019. They were followed a week later by league newcomers Guernsey, who also went down after just one season, following a heavy defeat away
2018–19 National League 2 South
2018–19_National_League_2_South
English rugby union club, based in Essex
League 2 East 2026–27 teams Barnes Canterbury Colchester Dorking Esher Guernsey Raiders Havant Henley Hawks Jersey Leicester Lions London Welsh Old Albanian
Westcliff_RFC
English rugby union club, based in Colchester
League 2 East 2026–27 teams Barnes Canterbury Colchester Dorking Esher Guernsey Raiders Havant Henley Hawks Jersey Leicester Lions London Welsh Old Albanian
Colchester_RFC
English rugby union club, based in Surrey
Esher RFC Full name Esher Rugby Football Club Union Surrey RFU Founded 1923; 103 years ago (1923) Location Hersham, Surrey, England Ground Molesey Road
Esher_RFC
English rugby union club, based in Orpington, London
Westcombe Park RFC is a rugby football club based in Orpington in south-east London. The name of the club comes from the Westcombe Park area of what is
Westcombe_Park_RFC
Wales Port Talbot Town Association football 232 Footes Lane 6,000 Guernsey Guernsey Guernsey Association football 233 Butlin Road 6,000 Rugby England Association
List of stadiums in the United Kingdom by capacity
List_of_stadiums_in_the_United_Kingdom_by_capacity
English rugby & association footballer
the 1960s and 1970s. He played club level rugby union (RU) for Llandaff RFC, representative level association football for Jersey, and at club level
Michael_Seatter
Level four rugby union league in England
4 tries or more in a match. Barnes Canterbury Colchester Dorking Esher Guernsey Raiders Havant Henley Hawks Jersey Leicester Lions L Welsh Old Albanian
National_League_2_East
publishing Bonsai Culture for Beginners in 1968. Larkin died at Saint Martin's, Guernsey on 20 June 1972, survived by two sons and a daughter. Smith, Ann G. (1983)
Herbert_Larkin
English rugby union football club
between 5 and 18. The club holds a fierce local derby with Old Reigatian RFC Dorking RFC was founded in 1921 with a single team; a second team followed in 1928
Dorking_R.F.C.
Internet top-level domain used by the US government
Homeland Security. gov is one of the original six top-level domains, defined in RFC 920. Though "originally intended for any kind of government office or agency"
.gov
Gibraltar Guernsey (Sark) Jersey Isle of Man Montserrat St Helena St Kitts & Nevis Turk & Caicos Clubs Anguilla Eels RFC Campo Gibraltar RFC Manx rugby
Saint Kitts and Nevis Rugby Association
Saint_Kitts_and_Nevis_Rugby_Association
English rugby union regional league
Epsom RFC Wimbledon Basingstoke Beckenham Chichester Cobham Dover Guernsey Haywards Heath Hove Old Elthamians Portsmouth RFC Sidcup Sutton & Epsom RFC Thanet
Regional_2_South_East
Rugby player
convicted of sexual assault and common assault following an incident in a Guernsey nightclub. He was sentenced to five months in prison, including three months
Matthew_McLean
English rugby union club, based in Leicestershire
between two local clubs in 1998, these being Westleigh RFC (established in 1904) and Wigston RFC (established in 1946). Leicester Lions boast several high-profile
Leicester_Lions_RFC
English rugby union club, based in Tonbridge, Kent
following their promotion from the 2024–25 National League 2 East. Tonbridge RFC was formed in 1904 and Old Juddians was formed in 1928. 'Old Juddians' were
Tonbridge_Juddians_RFC
English aircraft engineer (1882–1965)
continued to serve in the RFC during the war. On 5 August 1914, he was promoted to lieutenant and appointed a flying officer in the RFC from the same date.
Geoffrey_de_Havilland
Standard for area codes used by the United Nations
(first described in September 2006 in the now obsoleted RFC 4646, but confirmed in its successor RFC 5646, published in September 2009) for use within language
UN_M49
English rugby union club, based in West Sussex
Northampton Saints and Ulster before joining Worthing RFC. For the 2016/17 season, former Worthing RFC 1st XV coach and former director of rugby at Cornish
Worthing_RFC
Crown Dependency in the English Channel
(thus Geirrsey, 'Geirr's Island'). The ending -ey denotes an island, as in Guernsey or Surtsey. The La Cotte de St Brelade site on the southwest coast indicates
Jersey
Welsh judge (born 1951)
President, Welsh Tribunals, since 2017; a Judge of the Courts of Appeal of Guernsey and Jersey, since 2018". Who's Who 2021. Oxford University Press. 1 December
Wyn_Williams
Annual rugby union knock-out club competition
(2) Alton (1) Andover (1) Ellingham & Ringwood (1) Gosport & Fareham (1) Guernsey (1) Les Quennevais (1) Portsmouth (1) Romsey (1) Tottonians (1) Hampshire
Hampshire_Bowl_(rugby_union)
English rugby union club, based in Bury St Edmunds, Suffolk
840 960 −120 19 1 66 9 London Welsh 26 10 0 16 705 866 −161 16 8 64 10 Guernsey Raiders 26 11 1 14 690 875 −185 13 3 62 11 Esher 26 10 0 16 844 831 +13
Bury_St_Edmunds_RUFC
Rugby union competition in England
May 2026. "Regional 1 South Central Confirmed for Sevenoaks RFC in 2026/27". Sevenoaks RFC. Retrieved 31 July 2026. "Movers and Shakers: The 26/27 Promotion
2026–27 National League 2 East
2026–27_National_League_2_East
adopted by the Royal Naval Air Service (RNAS) and the Royal Flying Corps (RFC) during the First World War. Many Bessonneau hangars were also subsequently
Bessonneau_hangar
staff at Guy's Hospital in London in 1843, the Guy's, King's and St Thomas' RFC would be the oldest "football" club of any code. Nevertheless, the connection
Oldest_football_clubs
Rugby player
Siam from Guernsey". BBC News. 2 May 2009. "Jersey thrash Guernsey 73-5 to win the Siam Cup". BBC News. 14 May 2011. "Jersey win Siam but Guernsey fight bravely"
Michael_Le_Bourgeois
Level 9 rugby league in England
leaving eleven clubs to contest the outstanding fixtures. Departing were Guernsey Vikings, Sandown & Shanklin and Basingstoke, all promoted to Counties 1
Counties_2_Hampshire
Airport in South London, England, 1920–1959
to Belfast, Dublin, Liverpool, Manchester, Glasgow (Renfrew), Jersey, Guernsey, and several continental airports. A year later there were 56 departures
Croydon_Airport
Rugby union competition in England
tries or more in a match. Barnes Bury St Edmunds Canterbury Dorking Esher Guernsey Raiders Havant Henley Hawks L Welsh Old Albanian Oundle Oxford Harlequins
2025–26 National League 2 East
2025–26_National_League_2_East
English rugby union league
Teddington 39 11 Twickenham 38 12 Bognor 15 Bognor Effingham and Leatherhead Guernsey Guildford Gosport & Fareham KCS Old Boys London Cornish Old Reigatians
London_2_South_West
Australian rules football club
the club's official home ground. Richmond traditionally wears a black guernsey with a yellow sash. The club song, "We're From Tigerland", is well known
Richmond_Football_Club
Rugby team
Farnborough Farnham Fawley Fordingbridge Gosport & Fareham Guernsey Havant Hampshire Constabulary RFC Hook & Odiham Isle of Wight Jersey Reds Jersey United
Hampshire Rugby Football Union
Hampshire_Rugby_Football_Union
Topics referred to by the same term
Peter's, Nova Scotia St. Peters Canal, Cape Breton Island St Peter's, Guernsey St. Peters, County Roscommon, a civil parish in County Roscommon St. Peters
St._Peter's
Rugby union competition in England
2021–22 National League 2 North Record crowd Game moved to Chiswick RFC . Guernsey Raiders only played 14 homes games as their game versus Rochford Hundred
2021–22 National League 2 South
2021–22_National_League_2_South
English rugby union player
Rugby Network. 16 April 2012. Retrieved 6 January 2013. "JERSEY 1ST XV V GUERNSEY - SIAM CUP". Pitchero. 2 May 2013. "OEs make strong preparations for next
Ross_Broadfoot
Area that observes a uniform standard time
2019. The Time Zone Information Format (TZif). IETF. doi:10.17487/RFC8536. RFC 8536. Wikivoyage has a travel guide for Time zones. Media related to Time
Time_zone
English rugby union club, based in Essex
League 2 East 2026–27 teams Barnes Canterbury Colchester Dorking Esher Guernsey Raiders Havant Henley Hawks Jersey Leicester Lions London Welsh Old Albanian
Rochford_Hundred_RFC
Rugby union club in Norfolk, England
North Walsham R.F.C. is a rugby union club representing the market town of North Walsham in Norfolk. Between 1990 and 2008, the club competed in National
North_Walsham_R.F.C.
Air and space warfare force of the United Kingdom
World War on 1 April 1918 through the merger of the Royal Flying Corps (RFC) and the Royal Naval Air Service (RNAS). Following the Allied victory over
Royal_Air_Force
British Lions & Scotland international rugby union player & cricketer
Scotland international rugby union player. He was also a cricketer for Guernsey and Oxford University. He became a career soldier. Grieve was born in Manila
Charles_Grieve
RAF officer who served in World War I
second wife, Minnie LaRue who was from the Isle of Guernsey. The two married and returned to Guernsey. During World War II the islands were occupied by
John_Mitchell_(RAF_officer)
Rugby union competition in England
scoring 4 tries or more in a match. Bury St Edmunds Canterbury Dorking Esher Guernsey Raiders Henley Hawks London North Walsham Old Albanian Sevenoaks Tonbridge
2023–24 National League 2 East
2023–24_National_League_2_East
Royal Air Force officer
2015) was a Royal Air Force officer who served as Lieutenant Governor of Guernsey from 2011 to 2015. The son of a Royal Air Force (RAF) fighter pilot, Peter
Peter_Walker_(RAF_officer)
Level five rugby union league in England
Weston-super-Mare RFC. 2 April 2017. "Rugby round-up: Maidenhead RFC and Marlow RFC are both champions while win for Windsor RFC keeps survival hopes
Regional_1_South_West
Bermudan infantryman and aviator during the First World War
the RFC, the air arm of the British Army (the other was Henry Joseph Watlington), although more than a dozen other Bermudians would reach the RFC by different
Arthur_Spurling
Corporate-focused tax havens
regional financial centres (RFCs). A single financial centre may belong to multiple financial centre classes (e.g. Singapore is an RFC and an OFC). The Caribbean
Offshore_financial_centre
Top-level Internet domain for the UK
cn, .de and .net), with over 10 million registrations. In October 1984, RFC 920 set out the creation of ccTLDs using country codes derived from the corresponding
.uk
Number for local emergency services
including Bahrain, Bangladesh, Botswana, the Cook Islands, Eswatini, Ghana, Guernsey, Hong Kong, the Republic of Ireland, the Isle of Man, Jersey, Kenya, Macau
Emergency_telephone_number
Culture shared by LGBTQ people in Cardiff, Wales
Songbirds Choir. Retrieved 2023-02-18. "Cardiff Lions RFC - Inclusive Rugby Club". Cardiff Lions RFC. Retrieved 2026-01-24. "History - Cardiff Dragons".
LGBTQ_culture_in_Cardiff
consists of thirteen teams from England and one from the Channel Island of Guernsey. It will be the first season organised under the London & South East Premier
2017–18 London & South East Premier
2017–18_London_&_South_East_Premier
English rugby union club
League 2 East 2026–27 teams Barnes Canterbury Colchester Dorking Esher Guernsey Raiders Havant Henley Hawks Jersey Leicester Lions London Welsh Old Albanian
Blackheath_F.C.
Australian rules footballer (born 1996)
end he was upgraded to the Richmond's senior playing list and switched guernsey numbers from 45 to 15. Short's first senior match in 2017 came in Richmond's
Jayden_Short
Flying squadron of the Royal Air Force
MRA1 from RAF Lossiemouth, Moray. It is the only squadron affiliated with Guernsey, in the Channel Islands. This affiliation started in 1935 and is commemorated
No._201_Squadron_RAF
Set of telephony signaling protocols
the fleeing princess. Signals were sent via mobile networks in Jersey, Guernsey, Cameroon, Israel, Laos and the USA. "It is dangerously easy to hack the
Signalling_System_No._7
Rugby union competition in England
included Birmingham & Solihull (to Greater Birmingham Merit Leagues), Guernsey (London & South East Premier) and London Irish Wild Geese (South West Premier)
2019–20 National League 2 South
2019–20_National_League_2_South
Australian rules footballer
Medal (1st RFC B&F): 2011, 2012, 2014 Maurie Fleming Medal (3rd RFC B&F): 2016 Fred Swift Medal (4th RFC B&F): 2017 Kevin Bartlett Medal (5th RFC B&F): 2013
Trent_Cotchin
British flying ace (1896–1986)
home to serve as lieutenant colonel of the 5th Royal Veteran Battalion in Guernsey, then as Captain of Invalids and Hospital Major at the Royal Hospital Chelsea
Maurice_Leblanc-Smith
English rugby union sevens tournament
from which schools have participated included Canada, China, Denmark, Guernsey, Hungary, India, the Isle of Man, Jersey, Kenya, Nigeria, Poland, Romania
National_Schools_Sevens
London Scottish. 21 May 2014. "Cardiff RFC sign former Scotland international prop Bruce Douglas". Cardiff RFC. 3 June 2014. "Bristol and Argentina lock
List of 2014–15 RFU Championship transfers
List_of_2014–15_RFU_Championship_transfers
Market town in Warwickshire, England
(born 1960) UK Military Representative to NATO and Lieutenant Governor of Guernsey. William Dorsey (1813–1878), doctor and Australian pioneer George Finch
Nuneaton
Sovereign state in Northwestern Europe (1801–1922)
formed from the Royal Naval Air Service (RNAS) and the Royal Flying Corps (RFC), was about the same size of the pre-war army. The almost three million casualties
United Kingdom of Great Britain and Ireland
United_Kingdom_of_Great_Britain_and_Ireland
British pilot (1892–1966)
commission in 1944 on the grounds of ill health. He settled with his wife in Guernsey, and died in Charminster on 18 January 1966. Henri Charles Amédée de La
Henry_Biard
BBC Local Radio station for Derbyshire
Oxford Solent South East Kent Surrey Sussex South West Cornwall Devon Guernsey Jersey Somerset West Bristol Gloucestershire Wiltshire West Midlands CWR
BBC_Radio_Derby
Place which charges very low taxes on profits
delivered an integrated report on the three British Crown Dependencies (Guernsey, Isle of Man and Jersey), and the six Overseas Territories (Anguilla, Bermuda
Tax_haven
English level 10 Rugby Union league
Locksheath Pumas, relegated from Hampshire Premier, and Guernsey Vikings Lockheath Pumas RFC finished 4th in 2019-20, but were promoted to Hampshire Premier
Counties_3_Hampshire
Airport in West Yorkshire, England
Airlines Destinations Aer Lingus Belfast–City, Dublin Aurigny Seasonal: Guernsey easyJet Barcelona, Belfast–International, Paris–Charles de Gaulle (all
Leeds_Bradford_Airport
on land and not at sea. At the start of the war, the Royal Flying Corps (RFC), commanded by David Henderson, was sent to France and was first used for
History of the United Kingdom during the First World War
History_of_the_United_Kingdom_during_the_First_World_War
travel, tourism, insurance
GUERNSEY RFC
GUERNSEY RFC
GUERNSEY RFC
GUERNSEY RFC
GUERNSEY RFC
GUERNSEY RFC
GUERNSEY RFC
GUERNSEY RFC
GUERNSEY RFC
travel, tourism, insurance